The version 1.0.1 of the Talend SE is available

A maintenance release is available for the Petals’ Talend SE.
This Petals component allows one to expose Talend jobs as services in the bus.

The version 1.0 was released in April 2010.
The version 1.0.1 was released last week and brings some fixes:

  • A better management of exceptions (with respect to the WSDL and to the error details).
  • More flexibility with WSDL descriptions. This flexibility is very useful if you want to orchestrate several Talend jobs in a BPEL process.
  • An easier approach for notifications (in case where you also use the KPI component in your installation).

This component was almost released at the same time than Talend Open Studio 4.1.
The Petals export was updated in this new version of Talend tools (the generated WSDL were improved).
If you use the version 4.1 of Talend Open Studio (or the associated version of Talend Integration Suite) with Petals, then you should use the version 1.0.1 of the Talend SE. It will work with the version 1.0, but the component may return responses that do not match what the WSDL describes. That can be a problem with WSDL-based approaches (e.g. a hard-coded client or a BPEL process).

Here is the compatibility table:

TOS 4.0.x TOS 4.1
Talend SE 1.0 X
Talend SE 1.0.1 X X

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s